Search found 15 matches

by pablo_chumacero
Fri May 19, 2017 7:32 pm
Forum: Programming - API
Topic: Read Sensor trought UART
Replies: 8
Views: 5730

Re: Read Sensor trought UART

Hi guys, I'm trying use the library with GS3 sensor: https://www.decagon.com/en/soils/volume ... c-temp-ec/ But i don't recibe any data for my data line. I don't know if is my code or any conexion. I power my sensor with 5V and use the DIGITAL8 pin of Waspmote. My code is below: Code: #include <SDI1...
by pablo_chumacero
Wed May 17, 2017 7:18 am
Forum: Programming - API
Topic: SDI-12 library for Waspmote
Replies: 14
Views: 10181

Re: SDI-12 library for Waspmote

Hi guys, I'm trying use the library with GS3 sensor: https://www.decagon.com/en/soils/volumetric-water-content-sensors/gs3-vwc-temp-ec/ But i don't recibe any data for my data line. I don't know if is my code or any conexion. I power my sensor with 5V and use the DIGITAL8 pin of Waspmote. My code is...
by pablo_chumacero
Mon May 15, 2017 7:03 pm
Forum: Programming - API
Topic: Read Sensor trought UART
Replies: 8
Views: 5730

Re: Read Sensor trought UART

niomike wrote:I have successfully implemented an SDI-12 sensor with the waspmote. I talk about the process here: viewtopic.php?f=54&t=23450
Thank you so much niomike. I will try with my sensor and then I'll tell you
by pablo_chumacero
Thu May 11, 2017 6:32 pm
Forum: Programming - API
Topic: Read Sensor trought UART
Replies: 8
Views: 5730

Re: Read Sensor trought UART

Thanks for your reply. My second output is the one I tried sending a similar message from another microcontroller to waspmote. I tried the code you attached and it worked when I sent a message from another microcontroller, however, it didn't work when I tried the sensor, I think the sensor is not re...
by pablo_chumacero
Tue May 09, 2017 10:22 am
Forum: Programming - API
Topic: Read Sensor trought UART
Replies: 8
Views: 5730

Read Sensor trought UART

Hi, I'm trying read a sensor of Decagon Devices (GS3) trought UART. The problem I have is that the sensor sends me a character string via serial communication (UART) and I can't read this data. When excitation voltage is applied, the GS3 makes a measurement. Within about 50 ms of excitation three me...
by pablo_chumacero
Mon Nov 28, 2016 3:41 am
Forum: Programming - API
Topic: Problem with GPRS/GPS append data
Replies: 3
Views: 2820

Re: Problem with GPRS/GPS append data

Hi, Try including in the loop SD.ON(); because the uploadFile function turn OFF the SD when it finishes to upload the file. Regards Thank you so much. Now the code it's okay. :D Now, I have other question: I want recieve data from UART port, then I will use this data from UART to set time sleep on ...
by pablo_chumacero
Fri Nov 25, 2016 12:54 am
Forum: Programming - API
Topic: Problem with GPRS/GPS append data
Replies: 3
Views: 2820

Problem with GPRS/GPS append data

Hello, I have a waspmote v1.2, a smart water board and a GPRS / GPS module. I want to upload the data measured by the smart water card and the GPS location to an FTP server via the GPRS / GPS module. I have managed to attach the measured data to a .txt file and save it to the SD card. Subsequently t...
by pablo_chumacero
Wed Oct 19, 2016 7:09 am
Forum: Networking 802.15.4 / ZigBee / WIFI / GPRS / 3G / Industrial protocols...
Topic: Problem sent frame SX1272- Meshlium
Replies: 5
Views: 2878

Re: Problem sent frame SX1272- Meshlium

libelium-dev wrote:Hi,

You attempt that the frame doesn't have line break
<=>€#408421092#node_01#149#STR:Humedad 1=-0.04 & Humedad2=-0.04
#
Hope this solve the issue.
Regards.
Ok, but how do I make a line break?
by pablo_chumacero
Tue Oct 18, 2016 2:44 am
Forum: Networking 802.15.4 / ZigBee / WIFI / GPRS / 3G / Industrial protocols...
Topic: Problem sent frame SX1272- Meshlium
Replies: 5
Views: 2878

Re: Problem sent frame SX1272- Meshlium

libelium-dev wrote:Hi,

Could you test the basic example code to send data to meshlium with lora? Is Meshlium showing the data received?

Regards.
Hi,

I did the basic example code and the meshlium showed the data for example battery level.
by pablo_chumacero
Sat Oct 15, 2016 2:11 am
Forum: Networking 802.15.4 / ZigBee / WIFI / GPRS / 3G / Industrial protocols...
Topic: Problem sent frame SX1272- Meshlium
Replies: 5
Views: 2878

Problem sent frame SX1272- Meshlium

Hi, I want to send a frame that is a string of characters, this string contain data about humidity, for several Waspmote with SX1272 module 868 to a Meshlium Lora. But when I tried to send the data to Meshlium this do not, however, the UART port tells me that the frame has been sent. I do not know i...