Search found 19 matches

by agualdron
Tue Mar 28, 2017 6:01 pm
Forum: Networking 802.15.4 / ZigBee / WIFI / GPRS / 3G / Industrial protocols...
Topic: Xbee on Socket0 not working
Replies: 4
Views: 3119

Re: Xbee on Socket0 not working

Hi, sorry for my poor explanation. I want to use the Xbee module with the expansion board on socket0, to send and receive data wirelessy. I configured the Xbee modules (TX/RX<->RX/TX) in order to use the transparent mode, so the comunication will use common serial interface in both modules. When I t...
by agualdron
Fri Mar 24, 2017 12:01 am
Forum: Networking 802.15.4 / ZigBee / WIFI / GPRS / 3G / Industrial protocols...
Topic: Xbee on Socket0 not working
Replies: 4
Views: 3119

Re: Xbee on Socket0 not working

hi, If I connect the UART pair with cables to the UART AUX 2 pins, the module work as expecte with this code: void setup() { PWR.switchesON(ALL_ON); PWR.powerSocket(SOCKET1, 1); Utils.setMuxSocket1(); beginSerial(115200,1); delay(300); } void loop() { char c=0; char i = 0; PWR.switchesON(ALL_ON); PW...
by agualdron
Thu Mar 23, 2017 6:14 pm
Forum: Networking 802.15.4 / ZigBee / WIFI / GPRS / 3G / Industrial protocols...
Topic: Xbee on Socket0 not working
Replies: 4
Views: 3119

Xbee on Socket0 not working

Hello, I have an XBee Pro module on the expansion board connected to socket0. I want to use the XBee in transparent mode, so, I can use it as common serial interface. But I can't figure out what is wrong with my code. this is the code i'm using: void setup() { PWR.switchesON(ALL_ON); PWR.powerSocket...
by agualdron
Tue Jan 31, 2017 4:08 pm
Forum: General Questions
Topic: RS485 Module
Replies: 3
Views: 2353

Re: RS485 Module

hi,

Image

any idea?
by agualdron
Tue Jan 31, 2017 3:09 am
Forum: General Questions
Topic: RS485 Module
Replies: 3
Views: 2353

RS485 Module

Hi, I'm trying to get the module RS485 work, but the example trow an error: RS-485 did not initialize correctly I'm using WaspmotePRO 1.2 RS485 Board Example Code: _RS485_01_send_data Output of the code: E# RS-485 did not initialize correctly Hello this is RS-485 communication send data example. the...
by agualdron
Tue Aug 23, 2016 4:50 pm
Forum: Networking 802.15.4 / ZigBee / WIFI / GPRS / 3G / Industrial protocols...
Topic: SIM908 FTP Problem
Replies: 5
Views: 3073

Re: SIM908 FTP Problem

thank you for your help...

Apparently, the SIM card had problems, I changed the SIM card and everything work well.

Could you share the source where you found the meaning of the CME_CMS error, the list I use is incomplete, and many errors I get from the waspmote are always missing.
by agualdron
Fri Aug 19, 2016 3:48 pm
Forum: Networking 802.15.4 / ZigBee / WIFI / GPRS / 3G / Industrial protocols...
Topic: SIM908 FTP Problem
Replies: 5
Views: 3073

Re: SIM908 FTP Problem

Hello, I formatted the SD with the "SD Format Example", and I'm still getting the same error answer: Inside sendDataFTP Send command with 2 answers: AT+FTPSTATE Answer: 1 Send command with 2 answers: AT+FTPPUTNAME="/CH1608.TXT" Answer: 1 Send command with 2 answers: AT+FTPPUTPATH="/" Answer: 1 Send ...
by agualdron
Fri Aug 19, 2016 2:07 am
Forum: Networking 802.15.4 / ZigBee / WIFI / GPRS / 3G / Industrial protocols...
Topic: SIM908 FTP Problem
Replies: 5
Views: 3073

SIM908 FTP Problem

Hello, I was trying to upload a file to an FTP server and, but always get the same error answer :? . I tryed with different FTP servers, and compiling with API v22 y API v23. I have SIM908 module Here is the complete output of the program E# ************************** APN: lte.avantel.com.co LOGIN: ...
by agualdron
Fri Jun 24, 2016 6:06 pm
Forum: Over The Air Programming - OTA
Topic: OTA 3G REPROGRAMMING ERROR
Replies: 27
Views: 18787

Re: OTA 3G REPROGRAMMING ERROR

Finilly it works...


I forgot (but is not evident from the OTAP guide) to format the SD with the SD Format example before attempting to do OTA.

After formatting the SD, the requestOTA worked as expected.

I'm still using GPRS, later I will try 3G again.

Hope this help other users.
by agualdron
Thu Jun 23, 2016 2:11 am
Forum: Over The Air Programming - OTA
Topic: OTA 3G REPROGRAMMING ERROR
Replies: 27
Views: 18787

Re: OTA 3G REPROGRAMMING ERROR

Hello, I did some other test, to undestand whats going on... I tryed this code: void setup(){ USB.print(F("Program version: \n")); USB.println(Utils.getProgramVersion(), DEC); USB.print(F("Boot version: \n")); USB.println(Utils.getBootVersion(), DEC); USB.print(F("Program ID: \n")); Utils.getProgram...