Search found 25 matches

by jburgues
Mon Dec 02, 2019 4:36 pm
Forum: General Questions
Topic: GPS and Xbee802
Replies: 8
Views: 8143

Re: GPS and Xbee802

Thanks for the answer. But, switching ON and OFF the 4G module in every iteration would be very slow...and even slower if gpsStart() has to be called after switching on the 4G module (is this the case?) Do you think it will work if, instead of switching ON the 4G module every time, I simply call the...
by jburgues
Mon Dec 02, 2019 12:03 am
Forum: General Questions
Topic: GPS and Xbee802
Replies: 8
Views: 8143

Re: GPS and Xbee802

Hello, I have a similar issue than David, that I am unable to solve. I want to read the GPS from the 4G module and then interact with an Arduino board that I have connected to UART1 (Baud rate = 600). When I run the 4G_gps_autonomous_mode_example, I correctly get the GPS data. However, when I embed ...
by jburgues
Wed Oct 23, 2019 12:25 pm
Forum: Programming - API
Topic: send data from gateway to waspmote 868
Replies: 9
Views: 9113

Re: send data from gateway to waspmote 868

If I got it properly, I can send commands to my waspMote with a USB gateway configured with AP=2, provided the frames are formatted according to the API frame format of DIGI: https://www.digi.com/resources/documentation/Digidocs/90002002/Content/Reference/r_api_frame_format_900hp.htm Taking as refer...
by jburgues
Wed Oct 23, 2019 9:48 am
Forum: Sensor Boards
Topic: Gases Pro free analog/digital pins?
Replies: 5
Views: 4444

Re: Gases Pro free analog/digital pins?

Ok, this means that if I don't have a PM sensor I can use D1 for PWM output?

Thanks,
Javier.
by jburgues
Wed Oct 23, 2019 9:45 am
Forum: General Questions
Topic: GPS not working
Replies: 1
Views: 3807

GPS not working

Hello, I cannot get the GPS_01_gettin_basic_data example working on my waspMote. See below serial output with with GPS_DEBUG enabled in WaspGPS.h: GPS_01 example [GPS] Command: $PSRF100,0,115200,8,1,0*04 [GPS] Command: A0A200188102010101010101050101010101000100000001000012C00167B0B3 [GPS] init comma...
by jburgues
Wed Oct 23, 2019 1:25 am
Forum: Programming - API
Topic: send data from gateway to waspmote 868
Replies: 9
Views: 9113

Re: send data from gateway to waspmote 868

Hello, I have the same problem as rr4v: I want to send a command from my Windows PC to the waspMote and also receive frames from the waspMote in the PC. If I understood properly, the only thing I have to do is to change AP mode from 2 to 0 in the USB gateway using XCTU tool (DH-DL currently are 0x00...
by jburgues
Wed Oct 23, 2019 12:37 am
Forum: Sensor Boards
Topic: Gases Pro free analog/digital pins?
Replies: 5
Views: 4444

Re: Gases Pro free analog/digital pins?

I need to know if pin D1 is free to use or if it is shared with any other component of the waspMote, Gases Pro board, 4G or xBee868 modules.

Thanks,
Javier.
by jburgues
Fri Oct 18, 2019 2:21 pm
Forum: General Questions
Topic: Global variables
Replies: 1
Views: 3939

Global variables

Hello, I produced a sketch with only a few global variables, but when I compile, the compiler says: Global variables use 6,518 bytes (79%) of dynamic memory, leaving 1,674 bytes for local variables. Maximum is 8,192 bytes. Low memory available, stability problems may occur Where are these 6518 bytes...
by jburgues
Fri Oct 18, 2019 12:29 pm
Forum: Sensor Boards
Topic: read NDIR
Replies: 1
Views: 2536

read NDIR

Hello, In the readNDIR() function, the conversion to ppm is carried out in this line: // conc(mV) --> concentración(% LEL) conc = V_conc * sensor_config.m_conc; Where m_conc 3.125 according to the calibration parameters stored inside the sensor: SENSITIVITY: 3.125 mV/% LEL Two questions arise: 1) Is...
by jburgues
Wed Oct 16, 2019 9:59 am
Forum: General Questions
Topic: Incorrect Frame Sequence in binary frame
Replies: 3
Views: 4705

Re: Incorrect Frame Sequence in binary frame

I'm using waspMote Pro IDE v06.16 in Windows.

I believe this version uses the API v042.

Thanks,
Javier.