[Reference] *READ ME FIRST*: Waspmote PRO checklist

Questions about the Waspmote board and its modules
Locked
libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

[Reference] *READ ME FIRST*: Waspmote PRO checklist

Post by libelium-dev » Mon Sep 26, 2011 2:21 pm

1 INTRODUCTION

If you find difficulties using Waspmote, first please make sure you read the documentation available on the Development Section. http://www.libelium.com/development/

You should also search in the forum, as most of the possible questions have been answered there.

If the problem persists, and before writing in the forum, follow all the points of the next checklists.

2 UPLOADING CODE

The following steps must be done each time we must upload code, always:
  1. Make sure the battery is connected and charged.
    Image
    "DO NOT TRY TO RECHARGE THE NON-RECHARGEABLE BATTERY. IT MAY EXPLODE AND CAUSE INJURIES AND DESTROY THE EQUIPMENT. DEVICES WITH NON-RECHARGEABLE BATTERIES MUST BE PROGRAMMED THROUGH THE USB CABLE WITHOUT THE BATTERIES CONNECTED. PLEASE DOUBLE CHECK THIS CONDITION BEFORE CONNECTING THE USB. DO NOT CONNECT EITHER UNDER ANY CIRCUMSTANCE THE SOLAR PANEL TO A DEVICE WITH A NON-RECHARGEABLE BATTERY AS IT MAY EXPLODE AND CAUSE INJURIES AND DESTROY THE EQUIPMENT."
  2. Switch Waspmote ON (in the image, move both switches to the left).
    Image
  3. If your code uses other modules, then plug to Waspmote all the needed devices (XBee, communication modules, Sensor Board, etc).
  4. You have downloaded the latest version of the API available at http://www.libelium.com/development/was ... lications/
  5. You have selected right board in the IDE (tools → board)
    Image
  6. Connect Waspmote to your PC through the USB cable and select the right USB port (tools → serial port). If it is the first time you plug a Waspmote on your PC and you are unable to see the proper USB port, maybe you should install the latest FTDI drivers: http://www.ftdichip.com/Drivers/D2XX.htm

    Moreover, if you have troubles installing FTDI drivers and your computer is unable to recognize Waspmote, please follow the installation guide for your operating system on your next link: http://www.ftdichip.com/Support/Documen ... Guides.htm.

    Note: This process will be required only the first time.

    Note: The name of the USB ports depends on the OS and the particular PC you have. The best way to find the USB where Waspmote is connected is trial & error.

    Image
  7. Prepare your code for Waspmote. In our case, go to the template of the “hello_world” or copy and paste the text in the sketch.
  8. Save the sketch (the IDE has a button for that), for example with the name “hello_world”, and check the IDE states “Done Saving”.

    Image
  9. Compile the code and check there are no errors or warnings. The IDE should say “Done Compiling” after the progress bar ends.

    Image
  10. Upload the code to Waspmote: click the “Upload” button and wait a few seconds until the process ends; check there are no error messages, just “Done uploading”.

    Image

    Image
  11. Now open the serial monitor and see the output of your code. Remember to select the right baudrate (by default is 115200).

    Image

    Image
  12. If the sketch is using XBee, connect the Gateway to your PC through a USB port. The antenna must be connected to the Gateway's XBee too.
  13. Select this new device in the “Tools/Serial Port” menu (if it was not auto-detected) and open another serial monitor to see the gateway data.
  14. You can also open another graphical serial terminal application like CuteCom or GTKTerm to see the incoming wireless frames to the Gateway. Please note the correct configuration:

    Image

    NOTE: In fact, the MAC of the sender Waspmote can be also read on the bottom of its XBee:

    Image


    (*) For ZigBee and DigiMesh users: when the Gateway's red LED is not blinking, it means it is configuring the network. When the red LED blinks, the network is already configured and ready to be used.
3 Networking problems
If you have networking problems, please check first this tips:
  1. All XBees are in the same network that the Gateway (or Meshlium). In Waspmote's API, PANID parameter is set with “setPAN” function. You can also set this parameter for each XBee plugging it to the Gateway, and then connecting it to a PC: the Digi's X-CTU application helps to check and set the XBee's configuration. In this case, you must use the ATID command.
  2. All XBees are in the same channel. The CHANNEL parameter is set with “setChannel” function. If you want to do it in the X-CTU way, you must use the ATCH command.
  3. All Waspmotes are transmitting towards the MAC of the Gateway (or Meshlium).
  4. All XBees are configured to 115200 bps. In X-CTU, you can control data rates executing the ATBD command.
  5. All XBees have the same encryption options. The ENCRYPTION MODE parameter is set with ”encryptionMode” function. In X-CTU, the related command is ATEE. And the ENCRYPTION KEY parameter is set with “setLinkKey” function. In this case, the X-CTU command is ATKY.
  6. All Waspmotes' XBees are set in mode AP = 2 (API mode).
Details for the X-CTU operation (only use X-CTU if you are an advanced user, since you could damage your XBee modules because of your bad use):
  1. Place in the Gateway the XBee you need to configure. Then connect the Gateway to a USB port in your PC.
  2. Open the X-CTU application and configure it like that:
    Image
  3. Perform the test (there is a button for that) and check the application delivers a message similar to this one:
    Image
  4. Then go to the Modem Configuration tab, and select the Read option. We must check each parameter first, and if we want to change it, we will go to the Write option.
    Image
  5. Check the first parameter, CH:
    Image
  6. The PAN ID:
    Image
  7. The destination address (2 parts):
    Image
  8. The KY parameter (if needed):
    Image
  9. The data speed:
    Image
  10. The API options:
Image
(*) [just for ZigBee users] If you set to 1 the JV parameter (in ZigBee End Devices/Routers) and write it, the radio module will verify the Coordinator (if it has been configured) is on its operating channel when joining or coming up from a power cycle. If a coordinator is not detected, the router will leave its current channel and attempt to join a new PAN. This feature can be useful when several ZigBee End Devices or Routers have not been configured yet; this way you can get them connected to a existing network in a semi-automatic way.
If JV=0, the router will continue operating on its current channel even if a coordinator is not detected.

(*) If you needed to change your XBees configuration to the values by default set by Digi (NOT the same values by default that Libelium sets), you can do it in X-CTU. Note it is risky since you could let the XBee without communication. You can just press the button Read, then Restore and after that you will probably have to reset the XBee. You can Read again to check the change. Green values are OK, Blue values (if any) are those which could not be changed.




4 Usage and storage recommendations for the batteries

The rechargeable, ion-lithium batteries, like the ones provided by Libelium (capacities of 1150, 2300 and 6600 mA·h), have certain characteristics which must be taken into account:

- Charge the batteries for 24 hours before a deployment. The aim is to have the charge of the batteries at 100% of their capacity before a long period in which they must supply current, but it is not necessary to improve the performance.

- It is not advised to let the charge of the batteries go below 20% of capacity, since they suffer stress. Thus, it is not advised to wait for the battery to be at 0% to charge it.

- Any battery self-discharges: connected to Waspmote or not, the battery loses charges by itself.

- Maximum capacity loss: as the charge and discharge cycles happen, the maximum charge capacity is reduced.

- Batteries work better in cool environments: their performance is better at 10 ºC than at 30 ºC.

- At temperatures below 0 ºC, batteries can supply current (discharge), but the charge process cannot be done. In particular:
o discharge range = [-20, 60] ºC
o charge range = [0, 45] ºC

Locked

Who is online

Users browsing this forum: No registered users and 1 guest