Page 1 of 1

which API Version and IDE for Waspmote V1.2 ?

Posted: Fri Feb 01, 2019 11:47 pm
by Shakey7
Hi LIbelium Team

I have to get back to old waspmotes and plug&Sense V1.2 material, so I want to know which IDE and API version can I use for programming Meshlium Smart City (not pro) and waspmote v1.2 with sensor end gas board.
On Libelium website in old Development Section, the latest versions available are IDE V04 and API V023.

Can use IDE V05 and with which latest API ?

Thanks

Bernie

Re: which API Version and IDE for Waspmote V1.2 ?

Posted: Mon Feb 04, 2019 9:28 am
by libelium-dev
Hi,

The last API compatible with v12 devices is v032. You can download it from here.
http://downloads.libelium.com/waspmote-pro-api-v032.zip

On the other hand, Waspmote Pro IDE - v06 is compatible with v12 devices. You have to replace library folders with the above ones.
http://www.libelium.com/development/was ... lications/

Regards

Re: which API Version and IDE for Waspmote V1.2 ?

Posted: Tue Feb 05, 2019 4:35 pm
by Shakey7
HI Libelium team

Thanks for your quick feedback.
But tell me where do I have to insert waspmote-api folder (from V032) into waspmote IDE V612 folders ?
It's hard to find the procedure to follow in your website.

Have a nice day
Bernie

Re: which API Version and IDE for Waspmote V1.2 ?

Posted: Wed Feb 06, 2019 10:48 am
by libelium-dev
Hi Bernie,

You can find where locate the folders depending of your OS in the following link
http://www.libelium.com/downloads/docum ... pdf#page=3

Hope this helps.
Regards