IDE V5 APIV32 for MacOSX

Everything about programming the platform and using the Waspmote API
Post Reply
Shakey7
Posts: 33
Joined: Mon Jan 26, 2015 6:32 pm

IDE V5 APIV32 for MacOSX

Post by Shakey7 » Mon May 06, 2019 11:31 pm

Hi Libelium team,

I want to reprogram an old appliance PLug&Sense V12, but I don't have the suitable IDE and API versio for MacOsx Mojave.

It seems that I can use Waspmote IDE V5 with API V32 to program my P&S V12.
But I can't get it on your website , so please give me the link to download IDE V5 for Macosx with APIV32

I need it urgently, so I warmly thank you for your quick answer

Best regards
Bernie

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: IDE V5 APIV32 for MacOSX

Post by libelium-dev » Tue May 07, 2019 12:00 pm

Hi,

You can use the last IDE available in the web site but you have to replace the libraries with the API v032. You can download them from the following links
http://www.libelium.com/development/was ... lications/
http://downloads.libelium.com/waspmote-pro-api-v032.zip

You can find here the paths that you have to replace
http://www.libelium.com/downloads/docum ... pdf#page=3

Regards

Shakey7
Posts: 33
Joined: Mon Jan 26, 2015 6:32 pm

Re: IDE V5 APIV32 for MacOSX

Post by Shakey7 » Wed May 08, 2019 8:57 pm

Hi

I have done that several times but it never changed the API version. The version is still V40 :roll:
when I run waspmote IDE

The Libelium doc says : :geek:
For MACOSX :
• Waspmote.app/Contents/Resources/Java/examples/
• Waspmote.app/Contents/Resouces/Java/libraries/
• Waspmote.app/Contents/Resources/Java/hardware/waspmote/cores/waspmote-api/

When I unzip Waspmote pro IDE , I got
• Waspmote.app/Contents/Java/Resources/examples/ (1)
• Waspmote.app/Contents/Java/libraries/ (2)
• Waspmote.app/Contents/Java/hardware/waspmote/avr/cores/waspmote-api/ (3)
which is quite different.

Nevermind, so I unzip waspmote pro API V32 and I replaced directories in IDE by those in API V32
example in (1)
libraries in (2)
waspmote-api in (3)

Then I ruin Waspmote .... and I still have v040 API .

So I don't understand where's the bug

Waiting for a solution , thanks

Bernie

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: IDE V5 APIV32 for MacOSX

Post by libelium-dev » Thu May 09, 2019 9:42 am

Hi Berni,

Your steps are correct. The IDE shows API v040 but we think it is using API v032.

It shows API v040 because that information is saved in a file called boards.txt and that file wasn't replaced
menu.cpu=Processor

##############################################################

wasp1.name=Waspmote API v040

wasp1.upload.tool=avrdude
wasp1.upload.protocol=stk500v1
wasp1.upload.maximum_size=122880

wasp1.upload.maximum_data_size=8192
#wasp1.upload.maximum_ram_size=8192
#wasp1.upload.warning_ram_size=7168
wasp1.upload.disable_flushing=false

wasp1.upload.speed=115200

wasp1.build.mcu=atmega1281
wasp1.build.f_cpu=14745600L
wasp1.build.board=AVR_WASP
wasp1.build.core=waspmote-api
Regards

Shakey7
Posts: 33
Joined: Mon Jan 26, 2015 6:32 pm

Re: IDE V5 APIV32 for MacOSX

Post by Shakey7 » Thu May 09, 2019 1:33 pm

Hi Libelium DreamTeam,

Thanks for your feedback, it's ok but this should be mentioned in the libelium doc.

By the way, how can I check the API version that is mounted in the Waspmote package on MAcosx ?

Have a nice day

Bernie

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: IDE V5 APIV32 for MacOSX

Post by libelium-dev » Fri May 10, 2019 9:19 am

Hi,

When an IDE es downloaded from the web, it includes the last API available and you can see the message with the version on the screen.

When the API is replaced with another one, you should change the wasp1.name in boards.txt to remember the API used.

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest