Error code -28 working with 3G modul and external FTP server

Using OTA functions with Waspmote
Post Reply
BladeRunner
Posts: 8
Joined: Tue Jun 28, 2016 5:51 pm

Error code -28 working with 3G modul and external FTP server

Post by BladeRunner » Sun Sep 11, 2016 8:01 pm

Hi,

I'm trying to implement OTAP with a single Waspmote Plug and Sense (without Meshlium) with a 3G module. I have available a FTP server.

Although the connection is reachable, the user and password are correct and the _3G.requestOTA function detects a new firmware and Waspmote starts the downloading, at the end the result of the function is the error -28 (error downloading the OTA file).

My UPGRADE.TXT is:
FILE:MEASURE
PATH:/
SIZE:57464
VERSION:11
The size, in bytes, is the same size that the server indicates (and can be observed in FileZille). The file is in the same directory where the UPGRADE.txt file is (the root directory). The name of the file is not modified by me.

Current firmware version is 10, as the function Utils.getProgramVersion() says. For this reason I write VERSION:11 in the UPGRADE.txt file.

I have checked the SD card and its size is 1.86 GB, so this is correct.

I can't imagine any other problem... Could you give me a piece of advice, please?

Thank you!

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Error code -28 working with 3G modul and external FTP se

Post by libelium-dev » Mon Sep 12, 2016 9:36 am

Hi,

Maybe the issue is related with the configuration of your server, please try the OTA process against our test server.

pruebas.libelium.com
user:t3g@libelium.com
pass:ftp1234
port: 21

Also, did you check if there is some file at the SD of waspmote? You can try to format the SD with the example 12 of the IDE to discard any SD issue.

Regards

BladeRunner
Posts: 8
Joined: Tue Jun 28, 2016 5:51 pm

Re: Error code -28 working with 3G modul and external FTP se

Post by BladeRunner » Mon Sep 12, 2016 4:17 pm

Thank you very much for your answer.

After checking your example in your FTP server I realized that it was a problem in my UPGRADE.txt file. Althought I was very careful about its format, trying to respect to finish each line with the '\n' character, my Windows program to edit the text file inserted, actually, a carriage return plus a line feed characters. After deleting the carriage return character, the OTA process is working properly.

Kind regards.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Error code -28 working with 3G modul and external FTP se

Post by libelium-dev » Mon Sep 12, 2016 4:28 pm

Glad to hear you solve the issue!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest