IBM Bluemix connection with Meshlium

How to configure Meshlium or use the Manager System
Tox_project
Posts: 52
Joined: Mon May 28, 2018 7:38 pm
Company: U of S

Re: IBM Bluemix connection with Meshlium

Post by Tox_project » Wed Jun 20, 2018 11:19 pm

Hi dev,

I have a similar problem but I am unable to login through ssh into the meshlium. How can i proceed?

I have Meshlium 4, so ssh is disabled.

Regards,

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: IBM Bluemix connection with Meshlium

Post by libelium-dev » Thu Jun 21, 2018 9:17 am

Hi,

ssh isn't possible in Meshlium 4.

Could you explain in detail your problem?

Regards

Tox_project
Posts: 52
Joined: Mon May 28, 2018 7:38 pm
Company: U of S

Re: IBM Bluemix connection with Meshlium

Post by Tox_project » Thu Jun 21, 2018 6:42 pm

Hi dev,

This is what the log file reads, the type of devices are not being updated in the bluemix website, and thereby there are no updates of data. Since there is no ssh , I cant delete the file either.

[2018-06-20 16:04:13.114] [INFO] Device types loaded from file.
[2018-06-20 16:04:13.128] [INFO] Gateway loaded from file.
[2018-06-20 16:04:13.129] [INFO] Devices loaded from file.
[2018-06-20 16:04:13.478] [ERROR] Failed to get info from https://(my id).internetofthings.ibmcloud.com/api/v0002/device/types/MESHLIUM_DEV/devices. [cURL] 400: HTTP/1.1 400 Bad Request CUDRS0044E: Device GW_meshlium9d50 of type MESHLIUM_GW does not exist in organization (my id).
[2018-06-20 16:04:13.479] [INFO] Device 10 is out of the range of the list 10

[2018-06-20 16:04:13.805] [ERROR] Failed to get info from https://(my id).internetofthings.ibmcloud.com/api/v0002/device/types/MESHLIUM_DEV/devices. [cURL] 400: HTTP/1.1 400 Bad Request CUDRS0044E: Device GW_meshlium9d50 of type MESHLIUM_GW does not exist in organization (my id).
[2018-06-20 16:04:13.807] [INFO] Device 10 is out of the range of the list 10

[2018-06-20 16:04:14.218] [ERROR] Failed to get info from https://(my id).internetofthings.ibmcloud.com/api/v0002/device/types/MESHLIUM_DEV/devices. [cURL] 400: HTTP/1.1 400 Bad Request CUDRS0044E: Device GW_meshlium9d50 of type MESHLIUM_GW does not exist in organization (my id).
[2018-06-20 16:04:14.219] [INFO] Device 10 is out of the range of the list 10

[2018-06-20 16:04:14.601] [ERROR] Failed to get info from https://(my id).internetofthings.ibmcloud.com/api/v0002/device/types/MESHLIUM_DEV/devices. [cURL] 400: HTTP/1.1 400 Bad Request CUDRS0044E: Device GW_meshlium9d50 of type MESHLIUM_GW does not exist in organization (my id).
[2018-06-20 16:04:14.602] [INFO] Device 10 is out of the range of the list 10

[2018-06-20 16:04:14.925] [ERROR] Failed to get info from https://(my id).internetofthings.ibmcloud.com/api/v0002/device/types/MESHLIUM_DEV/devices. [cURL] 400: HTTP/1.1 400 Bad Request CUDRS0044E: Device GW_meshlium9d50 of type MESHLIUM_GW does not exist in organization (my id).
[2018-06-20 16:04:14.926] [INFO] Device 10 is out of the range of the list 10

[2018-06-20 16:04:15.247] [ERROR] Failed to get info from https://(my id).internetofthings.ibmcloud.com/api/v0002/device/types/MESHLIUM_DEV/devices. [cURL] 400: HTTP/1.1 400 Bad Request CUDRS0044E: Device GW_meshlium9d50 of type MESHLIUM_GW does not exist in organization (my id).
[2018-06-20 16:04:15.248] [INFO] Device 10 is out of the range of the list 10

[2018-06-20 16:04:15.596] [ERROR] Failed to get info from https://(my id).internetofthings.ibmcloud.com/api/v0002/device/types/MESHLIUM_DEV/devices. [cURL] 400: HTTP/1.1 400 Bad Request CUDRS0044E: Device GW_meshlium9d50 of type MESHLIUM_GW does not exist in organization (my id).
[2018-06-20 16:04:15.598] [INFO] Device 10 is out of the range of the list 10

[2018-06-20 16:04:15.937] [ERROR] Failed to get info from https://(my id).internetofthings.ibmcloud.com/api/v0002/device/types/MESHLIUM_DEV/devices. [cURL] 400: HTTP/1.1 400 Bad Request CUDRS0044E: Device GW_meshlium9d50 of type MESHLIUM_GW does not exist in organization (my id).
[2018-06-20 16:04:15.938] [INFO] Device 10 is out of the range of the list 10

[2018-06-20 16:04:16.268] [ERROR] Failed to get info from https://(my id).internetofthings.ibmcloud.com/api/v0002/device/types/MESHLIUM_DEV/devices. [cURL] 400: HTTP/1.1 400 Bad Request CUDRS0044E: Device GW_meshlium9d50 of type MESHLIUM_GW does not exist in organization (my id).
[2018-06-20 16:04:16.269] [INFO] Device 10 is out of the range of the list 10

[2018-06-20 16:04:16.614] [ERROR] Failed to get info from https://(my id).internetofthings.ibmcloud.com/api/v0002/device/types/MESHLIUM_DEV/devices. [cURL] 400: HTTP/1.1 400 Bad Request CUDRS0044E: Device GW_meshlium9d50 of type MESHLIUM_GW does not exist in organization (my id).
[2018-06-20 16:04:16.615] [INFO] Device 10 is out of the range of the list 10


[2018-06-20 16:04:18.244] [ERROR] Failed to get info from https://(my id).internetofthings.ibmcloud.com/api/v0002/device/types/MESHLIUM_DEV/devices. [cURL] 400: HTTP/1.1 400 Bad Request CUDRS0044E: Device GW_meshlium9d50 of type MESHLIUM_GW does not exist in organization (my id).

Any clue what to do next?

Regards,
Harsha

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: IBM Bluemix connection with Meshlium

Post by libelium-dev » Fri Jun 22, 2018 9:37 am

Hi,

It seems that your account isn't configured properly. Please try to configure your account again.
https://developer.ibm.com/recipes/tutor ... -meshlium/

Also please stop cloud synchronization, reset local config, save new configuration and start synchronization.

Regards

Tox_project
Posts: 52
Joined: Mon May 28, 2018 7:38 pm
Company: U of S

Re: IBM Bluemix connection with Meshlium

Post by Tox_project » Fri Jun 22, 2018 4:47 pm

Hi dev,

How should I reset local config if Meshlium 4 DOES NOT support ssh? I have deleted and recreated the service thrice by now, I have followed the steps exactly. All the three times.

Regards,

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: IBM Bluemix connection with Meshlium

Post by libelium-dev » Mon Jun 25, 2018 8:35 am

Hi,

There is button to do that in the Manager system.

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests