ATOP command not found

How to configure Meshlium or use the Manager System
Post Reply
isa_uma
Posts: 12
Joined: Wed Oct 18, 2017 11:11 am
Company: UNIV. DE MALAGA

ATOP command not found

Post by isa_uma » Thu May 10, 2018 8:02 pm

Hi !

I am trying to connect ZigBee modules to the network created by Meshlium. When I try to access to the PAN ID in Meshlium through SSH console using ATOP command, the problem is that this command is not founded.
https://imgur.com/a/36J3tTL

Do you have any idea or suggestion to solve this problem ?

Thank you in advance

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: ATOP command not found

Post by libelium-dev » Fri May 11, 2018 11:48 am

Hi,

You have to open the serial communication with the module.

Code: Select all

sensorParserD.sh stop
Then run the command capturer with the following parameters:

Code: Select all

capturer S0 38400
Then write

Code: Select all

+++
DO NOT PRESS ENTER AFTER TYPING +++
This should return an OK message from your radio. And then you should be able to communicate with Zigbee module.

Regards

isa_uma
Posts: 12
Joined: Wed Oct 18, 2017 11:11 am
Company: UNIV. DE MALAGA

Re: ATOP command not found

Post by isa_uma » Fri May 11, 2018 4:20 pm

Hi again !

Thank you ! It worked. but, how can I know what the PAN ID is ?
I have read that I have to use the command ATOP, but I don`t receive anything.

Regards.

isa_uma
Posts: 12
Joined: Wed Oct 18, 2017 11:11 am
Company: UNIV. DE MALAGA

Re: ATOP command not found

Post by isa_uma » Sun May 13, 2018 4:29 pm

Hi.

After typing +++ as quick as posible, is doesn`t happend anything. I have been waiting for a 30 minutes and nothing. Also I have tried, but It's always te same:
https://imgur.com/a/7CYn5Rs

Aditionally, when I try to send from to Meshlium, these are received, but I can not reconigze them
https://imgur.com/oMwtsof

Can you give any clue ? Is it possible that my Meshlium is damaged ?

Thank you.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: ATOP command not found

Post by libelium-dev » Mon May 14, 2018 11:39 am

Hi,

The command sensorParserD.sh stop didn't worked. Is Meshlium updated to the last version? If not, please update Meshlium to the last Meshlium, you can do that through the Manager System.

Also please try this
Try this:
Stop sensorParser service:

Code: Select all

sensorParser.sh stop
Then, start capturer in USB0 port:

Code: Select all

capturer USB0 38400
Press:

Code: Select all

+++
Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests