Bonding Falied

Post Reply
elsalti
Posts: 3
Joined: Fri Sep 29, 2017 7:29 pm
Company: Sheridan College

Bonding Falied

Post by elsalti » Mon Oct 02, 2017 1:21 pm

Hi,
I have been trying to connect to MySignals SW via my phone (Bluetooth) and it asks me for the pin and I entered it. It then asked me two or three times again and I kept entering new pin numbers. Afterwards, it was never connected. When I kept doing it now, it says "bonding failed and try after 10 seconds" but with no luck. I did try with another phone and I had the same problem (i.e. entered the pin numbers multiple times and then bonding failed). Note both of the phones are based on android OSs.

Thanks in advance,
Tarek

libelium-dev
Posts: 26339
Joined: Mon Sep 28, 2009 1:06 pm

Re: Bonding Falied

Post by libelium-dev » Mon Oct 02, 2017 1:28 pm

Hi Tarek,

Please can you tell us the model of your mobile phone, your Android version and the version of MySignals firmware? Try deleting all bonded devices on MySignals device and also reset bondings on your Bluetooth settings in the mobile phone, lastly reset the Bluetooth radio on your mobile device by switching off and on. After that try to bond your mobile again with MySignals device.

Regards

elsalti
Posts: 3
Joined: Fri Sep 29, 2017 7:29 pm
Company: Sheridan College

Re: Bonding Falied

Post by elsalti » Mon Oct 02, 2017 2:28 pm

Hi,
Thanks for the reply. My phone is Galaxy S7 (Model no is SM-G930W8) and OS is Android 7.0. For the other phone, it is not with me now so I am not sure about the full specs other than it is a Google Pixel. I also tried to update the firmware and I downloaded and installed 1.0.10 (i.e., I was very careful that I did not plug or unplug anything in order not to effect the stability of the device). I also tried 1.0.1 but it seems it was not working (the screen froze on the MySignals device). I am not sure but how to delete all the bonded devices on MySignals? Since on the screen it just shows Bluetooth Connection (on/off) and Server Connection (on/off).
On the phone side, I unpaired Mysignals and restarted the mobile device. I also tried to switch on/off the Bluetooth on both sides with no luck.

Thank you in advance,
Tarek

libelium-dev
Posts: 26339
Joined: Mon Sep 28, 2009 1:06 pm

Re: Bonding Falied

Post by libelium-dev » Mon Oct 02, 2017 2:50 pm

Hi Tarek,

To delete bondings from MySignals do not select any option on Bluetooth Connection/Sensor Connection and press Start Monitoring, then press the icon on the bottom right corner (a gear icon), on the Bluetooth section you can see the delete bondings button.

The Android application has been tested on many Android devices, we tested the application also on Android 7.0.

Please try again and let us know your thoughts.

Regards

elsalti
Posts: 3
Joined: Fri Sep 29, 2017 7:29 pm
Company: Sheridan College

Re: Bonding Falied

Post by elsalti » Mon Oct 02, 2017 3:10 pm

Hi,
Thank you for your reply.
I did follow the steps and it worked out! Were these instructions on the technical document?

Just want to mention what happened while the problem was fixed:
I just want to mention that when I deleted the bonding devices, I found two devices. I switched on the Bluetooth on my phone and then I entered the pin number provided. The MySignals connected and then disconnected. Then I went to the app and clicked on devices and found the MySignals there. I clicked on it and then the app restarted. On the MySignals's screen, it showed connected and disconnected again. Then a message was shown on the app mentioning if you want to try again or Cloud data (I think since I cannot remember the actual message). Then I clicked on try again and since then it has been connected!

Thank you,
Tarek

libelium-dev
Posts: 26339
Joined: Mon Sep 28, 2009 1:06 pm

Re: Bonding Falied

Post by libelium-dev » Tue Oct 03, 2017 8:09 am

Hi Tarek,

You can check the full documentation in the following url:

http://www.libelium.com/downloads/docum ... _guide.pdf

Glad to hear you solved the issue!! If you have more questions please do not hesitate and drop us a line.

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests