Beplus tests and issues

Post Reply
Beplus
Posts: 3
Joined: Thu Nov 16, 2017 1:06 am
Company: Science Marketing

Beplus tests and issues

Post by Beplus » Wed Nov 29, 2017 5:04 pm

Hi My Signals,

We have used the device quite a lot and haven't had a 100% comfortable or user friendly experience.
Im here to share our main issues and observations with the hope that we can get full use of the product.

We have updated firmware and the app.
We have deleted bondings and tried to pair or bond to no avail with quite a few of the instruments.

We have only successfully been able to use the blood pressure arm strap monitor via bluetooth.
the scale does not pair nor transmit data to the device, same for the temp and blood Oxygen finger monitor.

The app itself has faulty and infrequent connections to the device, and repeatedly crashes when bluetooth is activated.


Here is our report
FOLDER WITH REPORT PLUS PICTURES AND VIDEOS OF PROBLEMS AVAILABLE ON GOOGLE DRIVE.

https://drive.google.com/open?id=17r0sq ... tDM0dWqmjo


We have tested mysignals cloud device and app and found many issues with its performance even when following the provided training videos.
We will try and enumerate the issues we found.

Starting with the device.

1. The device only successfully paired via bluetooth with the blood pressure monitor.
The rest of the devices did not pair with the mysignals central device.

2. The device infrequently connects to the app and fails the majority of the times when attempting to connect.

Those are the errors we have come across, we have attached video and pictures to help further diagnose the issue.

Usability Feedback for future versions.

We understand we are on the cutting edge with this technology and your team is working hard to continue improving the app across version releases, we want to help that process as a beta tester team with these UI & UX suggestions.

The device requires erasing and re-entering of wifi networks for connecting and does not store the network ID nor security type nor passphrase.

Storing wifi credentials is a must have functionality for a traveling medic and to take full advantage of the equipments portability.


The App is available in Spanish, however the device is not translated to spanish for regional applications and mass appeal in Spanish speaking countries.

Science Marketing can assist in providing a certified medical translation for the device so your team can implement quicker this highly desired and anticipated requirement.

The APP

App errors, the app fails to connect with the device 35% of the time, and recently has begun to stall and eventually crash when bluetooth is activated and connection is finally established.


Error screenshots provided.

The Readings veracity.

On the few opportunities the device functioned properly and was able to produce readings we were met with readings that oscillated wildly and this produced some doubts as to the accuracy of the readings. In our region health monitoring equipment are required to have a calibration function and test to confirm the readings veracity. We were not able to find this option, please advise as to the appropriate method to calibrate or to provide needed calibration verification or certification if available.

Thank you!

:D

libelium-dev
Posts: 26565
Joined: Mon Sep 28, 2009 1:06 pm

Re: Beplus tests and issues

Post by libelium-dev » Wed Nov 29, 2017 5:41 pm

Hi Beplus,

Thanks for your feedback, we really appreciate it. :D

Please be aware that if you unpair MySignals device from bluetooth settings on your mobile phone you should delete bondings on MySignals device. If you delete a bluetooth connection from one side (mobile phone) you should delete the bluetooth pairing on the other side (MySignals device) as one part of the encrypted connections disappears (when you unpair the device).

In order to start bluetooth mode in MySignals device you should select bluetooth mode and the press the button "Start monitoring" to enter bluetooth mode (if you do not press "Start monitoring" button, after select bluetooth mode, the mobile application will not discover MySignals device), then you can open the mobile application and it will look for new MySignals devices. Sometimes bluetooth stack from Android devices behaves abnormally because each manufactuturer implements its own management intructions to use the bluetooth, if this happens please switch on and off your bluetooth radio from the mobile phone.

After deleting both sides of the bluetooth bonding connection you can pair again the MySignals mobile application and the MySignals device. Start bluetooth mode in MySIgnals device and open the mobile application, it will prompt you a message to enter the PIN code as long as the MySignals device shows also the PIN code. To learn how to delete bondings on MySignals device, go to page 41 on our technical guide: http://www.libelium.com/downloads/docum ... df#page=41

You can find more information about MySignals on our technical guide: http://www.libelium.com/downloads/docum ... _guide.pdf

We will review your UX suggestions and we will add them as soon as possible.

Thank you so much

libelium-dev
Posts: 26565
Joined: Mon Sep 28, 2009 1:06 pm

Re: Beplus tests and issues

Post by libelium-dev » Thu Nov 30, 2017 8:51 am

Hello again Beplus,

we would like to make some more clarifications. Today our latest firmware revision for MySignals is 1.0.3 in which we make improvements in the stability of Bluetooth, can you confirm that you have updated to this version?

MySignals is able to remember the credentials of the WiFi key, for this it is necessary to go to Settings -> WiFi and write your credentials there.

MySignals SW always comes out of libelium with all BLE sensors paired and tested, so it was not necessary for you to scan any of them. They were ready to work. As we can see in the videos you have already made several sensor scans and this should only be done once, the following times the connection is automatic.

On the other hand we see in the video that you have not selected the correct sensors in MySignals, please check our tutorial to see which sensors you must select in MySignals for the BLE sensors (they are in the row below). For example SPO2 BLE is this:
Image

On the other hand, the BLE sensors can not connect both to MySignals and the Mobile App at the same time, it is necessary to choose one functionality or another.

Again, thanks for your feedback, we hope that all your questions are resolved.

Regards

Beplus
Posts: 3
Joined: Thu Nov 16, 2017 1:06 am
Company: Science Marketing

Re: Beplus tests and issues

Post by Beplus » Mon Dec 11, 2017 6:01 pm

Hello! Thank you for all the responses.

Yes I can confirm we did upgrade the firmware and did gain some better use, however still there is a general cumbersomeness with the use between device and app and the sensors. I will reattempt to test following the deleting bondings procedure and start fresh to see if we can get the desired use.

Kindest regards,
Beplus

libelium-dev
Posts: 26565
Joined: Mon Sep 28, 2009 1:06 pm

Re: Beplus tests and issues

Post by libelium-dev » Tue Dec 12, 2017 8:05 am

Hi Beplus,

Thanks for your feedback, if you have more questions please do not hesitate and drop us a line.

Regards

Beplus
Posts: 3
Joined: Thu Nov 16, 2017 1:06 am
Company: Science Marketing

Re: Beplus tests and issues

Post by Beplus » Thu Dec 14, 2017 3:08 pm

Hello Friends at Mysignals,

I have uploaded tests performed and issues experienced in a new batch of videos.

https://drive.google.com/open?id=1abKi3 ... UICrQUbly9

Thank you again for your help!

libelium-dev
Posts: 26565
Joined: Mon Sep 28, 2009 1:06 pm

Re: Beplus tests and issues

Post by libelium-dev » Thu Dec 14, 2017 4:04 pm

Hi Beplus,

we will try to answer each of your videos:

VID_20171212_121025
You only need to select the sensor in the last row in your case, which has a few small waves indicating that it is the BLE sensor. Please, when you see it in green, press again the sensor to enter in detail mode of that sensor and check if the connection is done then.

VID_20171212_121425
We are glad that this sensor is working correctly, again, we recommend you enter the sensor's detail mode to be able to see all the variables that the sensor can give.

VID_20171212_125112
During this video it seems that there is some type of communication failure between the screen and the mysignals microcontroller. We are still working on improving the firmware so this does not happen, if you detect in what situations this happens, we welcome all the possible feedback to solve all the problems. That it's to say, by now in cases where you do not get any message when trying to connect via wifi or on the GSR sensor, please restart MySignals and try again.

VID_20171212_125802
This video is recorded right after the previous one, so if a reset has not been made yet it is not functional, please try to restart and try again both the GSR sensor and EMG.

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest