Blood pressure sensor not working with both cable and bluetooth

madhukoirala
Posts: 22
Joined: Thu Jun 20, 2019 6:31 pm
Company: Serit IT Partner

Blood pressure sensor not working with both cable and bluetooth

Post by madhukoirala » Sun Jun 30, 2019 1:09 pm

Hi

I have been testing the MySignals sensors but failed to test blood pressure.
Using cable it detects but fails to measure.
Using bluetooth it does not show anything.

When I turn it on, a blue light starts blinking.
For BLE, I checked if MAC address of the sensor is configured in the main device and it is there rightly selected.

For images: https://drive.google.com/drive/folders/ ... tZHYIseTo2

Thanks
Madhu

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Blood pressure sensor not working with both cable and bluetooth

Post by libelium-dev » Mon Jul 01, 2019 8:43 am

Hi Madhu,

The cable is used to recharge the internal battery of the sensor. The blood pressure BLE sensors can't be read using the cable connected to MySignals.

Sometimes MySignals can't read the BLE sensors due to the low battery of them. Please charge it and try again.

Regards

madhukoirala
Posts: 22
Joined: Thu Jun 20, 2019 6:31 pm
Company: Serit IT Partner

Re: Blood pressure sensor not working with both cable and bluetooth

Post by madhukoirala » Wed Jul 03, 2019 3:33 pm

Hi

I have charged the sensor for two nights but still it is not working.
Actually instead of a steady blue light it just blinks. I guess it should be a continuous blue light after it is on.
Please suggest.

Thanks
Madhu

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Blood pressure sensor not working with both cable and bluetooth

Post by libelium-dev » Fri Jul 05, 2019 7:35 am

Hi,

Could you please share a video of the behaviour with us? Please select only the blood pressure sensor and enter the detail sensor view (graph).

Regards

madhukoirala
Posts: 22
Joined: Thu Jun 20, 2019 6:31 pm
Company: Serit IT Partner

Re: Blood pressure sensor not working with both cable and bluetooth

Post by madhukoirala » Mon Jul 08, 2019 4:01 pm

Hi

It's working now. It was the battery problem. I charged it for three consecutive days and it worked. However, the readings seem to be not so reliable.
It has huge deviation from the real pressure. It shows 100/50.
Also, does the interval setting work? I tried with 2 min setting which means it has to measure blood pressure every two minutes but it does not.

Thanks
Madhu

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Blood pressure sensor not working with both cable and bluetooth

Post by libelium-dev » Tue Jul 09, 2019 1:57 pm

Hi,

Why do you say the readings aren't reliable? What is the deviation? 100/50 can be real pressure.

Yes, the interval settings should work. If you set 2 minutes, the sensor should take measurements every 2 minutes. Could you please share a video of the behaviour of the sensor with us?

Regards

madhukoirala
Posts: 22
Joined: Thu Jun 20, 2019 6:31 pm
Company: Serit IT Partner

Re: Blood pressure sensor not working with both cable and bluetooth

Post by madhukoirala » Wed Jul 10, 2019 4:22 pm

Hi

Please find the video in the below link.

https://drive.google.com/open?id=1-NgOu ... OOQBY4f_AZ

Thanks
Madhu

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Blood pressure sensor not working with both cable and bluetooth

Post by libelium-dev » Thu Jul 11, 2019 8:45 am

Hi Madhu,

Thanks for the video. It seems that there is a bug in the firmware, we are going to perform some tests and we will let you know our findings as soon as possible.

Regards

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Blood pressure sensor not working with both cable and bluetooth

Post by libelium-dev » Thu Jul 11, 2019 1:55 pm

Hi,

We have just tested the sensor and we have the same result than you.

The MySignals device sends a "keep-alive" command to the sensor to keep it ON (by default it is power OFF after a few seconds without use) but it seems that some BLE packets are lost and therefore the sensor is turned OFF. We are going to try to improve the firmware but for now, the way to solve it is turning the sensor ON manually when it is OFF (the blue light is OFF).

Regards

madhukoirala
Posts: 22
Joined: Thu Jun 20, 2019 6:31 pm
Company: Serit IT Partner

Re: Blood pressure sensor not working with both cable and bluetooth

Post by madhukoirala » Tue Nov 12, 2019 1:26 pm

Hi

The readings are not reliable because when I check the pressure with other devices, they show a higher readings(115/75) but with Mysignals blood pressure sensor, it always shows lower readings(100/50) or even lower sometimes.

Madhu

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest