Azure

Development questions: create new plugins, add new features...
Valeria_vix
Posts: 8
Joined: Tue Mar 21, 2017 2:30 pm

Re: Azure

Post by Valeria_vix » Mon Mar 27, 2017 10:46 pm

Hi

Even though I have some issues with Azure now, it might come from the Meshlium's configuration. This is why I have to ask: When I make the connection between Meshlium and Azure, which is the format of the frame I send?This is my template file:

"idd": "#ID#",
"id_wasp": "#ID_WASP#",
"id_secret": "#ID_SECRET#",
"sensor": "#SENSOR#",
"valuee": "#VALUE#"

Do I have to put {....} or this is enough? I would actually like to know how this template it's filled. I mean, the file I send looks like this (12, "my_node",3294,"HUMA",4.56) ? Or if you know a way to see in a file the frames I send from Meshlium to Azure :D. I would also like to know the datatype of each one.

Regards

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Azure

Post by libelium-dev » Tue Mar 28, 2017 9:50 am

You can find the description of the identifiers in the Meshlium technical guide:

http://www.libelium.com/downloads/docum ... 10%3A18898

Or just a help dialog will appear if you leave the mouse pointer over the template text box.

You should not have problems with the default template, but some users report that a template without line feeds and with brackets works better. Please, try with this example:

Code: Select all

{"id": "#ID#", "id_wasp": "#ID_WASP#", "id_secret": "#ID_SECRET#", "sensor": "#SENSOR#", "value": "#VALUE#", "datetime": "#TS("c")#"}
Regards

Valeria_vix
Posts: 8
Joined: Tue Mar 21, 2017 2:30 pm

Re: Azure

Post by Valeria_vix » Tue Mar 28, 2017 2:23 pm

Hi
Now it works! Thank you!

Have a nice day!
Valeria

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Azure

Post by libelium-dev » Tue Mar 28, 2017 2:55 pm

You are welcome

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest