Meshlium System with Voyage

Development questions: create new plugins, add new features...
Post Reply
Posts: 1
Joined: Thu Oct 01, 2009 11:40 am

Meshlium System with Voyage

Post by anavas » Thu Oct 01, 2009 11:42 am

I tried Meshlium manager system in voyage linux running on alix1c box. I tried saving the confguration, but it seems like it is not saving it, can you guys please help ?

Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Meshlium System with Voyage

Post by libelium-dev » Thu Oct 01, 2009 12:33 pm

Hi anavas.

The problem is probably involved with perms.

You can try this actions:

* Check that www-data user is on sudoers with no password. You should write a line like this at the end of your sudoers file (with visudo command of course)

Code: Select all

%www-data       ALL=NOPASSWD:ALL
To check that www-data is on sudoers just as root execute

Code: Select all

su www-data
sudo ls -la 
If no password is required and the output of ls -la is shown, www-data can execute commands with sudo.

* Check that www-data is the owner of /var/www/meshlium (or the path of your manager system folder) to do that simply execute as root:

Code: Select all

chown -R www-data:www-data /var/www/meshlium
chmod -R ug+w /var/www/meshlium
After this steps manager system should be able to write files. But if you continue with problems we can try some more checks.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest