Smart Water EC sensor proving strange results

Questions about the Waspmote v15 and its modules
nguillou
Posts: 41
Joined: Wed Jun 05, 2019 9:58 am
Company: ANIAN

Smart Water EC sensor proving strange results

Post by nguillou » Thu Oct 03, 2019 2:47 am

Hi,

I have a Smart water device with PH, DO, EC and temperature sensors. I put the device in service (fish farm) 2 days ago and the results of the EC sensor are not stable at all.
Attached are pictures of dashboard results and raw data (payload) coming from Actility network server
https://ibb.co/3Nxfkzq
https://ibb.co/yyGyNv5

Note that other sensors do no show any apparent problem

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Smart Water EC sensor proving strange results

Post by libelium-dev » Fri Oct 04, 2019 1:22 pm

Hi,

Could you please check the output through the serial monitor during a couple of days and then share the output with us?

Is there any water pump close to the node or something that could cause interferences?

Regards

nguillou
Posts: 41
Joined: Wed Jun 05, 2019 9:58 am
Company: ANIAN

Re: Smart Water EC sensor proving strange results

Post by nguillou » Sat Oct 05, 2019 11:37 am

To monitor via serial port, I need to take back the device from customer for few days. Not sure, how it can be done quickly

nguillou
Posts: 41
Joined: Wed Jun 05, 2019 9:58 am
Company: ANIAN

Re: Smart Water EC sensor proving strange results

Post by nguillou » Mon Oct 07, 2019 2:32 am

Hello,

Below are the serial port monitoring during calibration process

https://ibb.co/JnMKw9Z
https://ibb.co/RhjbWPq

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Smart Water EC sensor proving strange results

Post by libelium-dev » Tue Oct 08, 2019 12:47 pm

Hi,

Did you wait until the resistance values are stable?

Please share with us a .txt file with the output through the serial monitor when you will be able to get it.

Regards

nguillou
Posts: 41
Joined: Wed Jun 05, 2019 9:58 am
Company: ANIAN

Re: Smart Water EC sensor proving strange results

Post by nguillou » Tue Oct 08, 2019 2:38 pm

Yes, We have waited until stable out put.

I don't have text file right now

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Smart Water EC sensor proving strange results

Post by libelium-dev » Thu Oct 10, 2019 9:02 am

Let us know we you were able to get the output through the serial monitor.

Regards

nguillou
Posts: 41
Joined: Wed Jun 05, 2019 9:58 am
Company: ANIAN

Re: Smart Water EC sensor proving strange results

Post by nguillou » Thu Oct 24, 2019 12:37 pm

Hi, I took back the device and did calibration using the solution provided by Libelium. Below are the results :
https://ibb.co/F3L3t7N
https://ibb.co/1nCJD3f
https://ibb.co/Y8WX1cq
https://ibb.co/0Z1RP5L
https://ibb.co/5WsCBVH
https://ibb.co/M2LK3mv
https://ibb.co/VDnrsVH

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Smart Water EC sensor proving strange results

Post by libelium-dev » Mon Oct 28, 2019 10:57 am

Hi,

What is the concentration (uS/cm) of the calibration bottles used for the conductivity sensor?

We think that the conductivity variations of the graph were caused by external interferences, such as water pump or electric devices close to the sensors.

Regards

nguillou
Posts: 41
Joined: Wed Jun 05, 2019 9:58 am
Company: ANIAN

Re: Smart Water EC sensor proving strange results

Post by nguillou » Sun Nov 03, 2019 8:21 am

Hi

12880 and 80000 which have been delivered to us. The other solutions are lower concentration

I took back the device at my office to do testing with sea water in bechet.Still values do not look stables as the water condition from the bechet is not changing but the values are changing between 13000 and 63000

Also, no power source close to the device

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest