Incorrect Frame Sequence in binary frame

Questions about the Waspmote v15 and its modules
Post Reply
jburgues
Posts: 25
Joined: Tue Jul 23, 2019 10:47 am
Company: IBEC

Incorrect Frame Sequence in binary frame

Post by jburgues » Tue Oct 15, 2019 10:54 am

Hello,

I noticed that Frame SEQ number in the header of the binary frame, used to detect missing frames, is incorrect for two values: 17 & 19.

I am using Xbee_868.

See attached plot of FrameSEQ versus time (https://ibb.co/D92L7RB) and log (https://gofile.io/?c=8pLfie).

The peaks you see correspond to FRAME_SEQ values 17 & 19 being incorrenctly sent as 125.

Is this something you already notices or is particular to my waspmote or IDE?

The same thing does not happen to me when using ASCII frames.

Thanks,
Javier.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Incorrect Frame Sequence in binary frame

Post by libelium-dev » Wed Oct 16, 2019 8:49 am

Hi,

What API version are you using? We are going to do some tests.

Did you try with the latest API v042?

Regards

jburgues
Posts: 25
Joined: Tue Jul 23, 2019 10:47 am
Company: IBEC

Re: Incorrect Frame Sequence in binary frame

Post by jburgues » Wed Oct 16, 2019 9:59 am

I'm using waspMote Pro IDE v06.16 in Windows.

I believe this version uses the API v042.

Thanks,
Javier.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Incorrect Frame Sequence in binary frame

Post by libelium-dev » Thu Oct 17, 2019 9:24 am

Hi Javier,

We have just tested the binary frames and they are created properly at 17 and 19 frame sequence. Could you please share the output through the serial monitor with us? Make sure that the frames are printed though the serial monitor to check if they are created properly.

Could you please check are you sending data to Meshlium? If so, please send us the sensorParser1.log file to debug the issue in more deep. You can download it accessing the logs ftp.
http://www.libelium.com/downloads/docum ... df#page=29

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest