Smart Agriculture v3.0 not reading sensors

New sensors integration, sensor boards usage...
Post Reply
IoTmonsta
Posts: 1
Joined: Tue Jun 18, 2019 7:59 am
Company: Timbergrove

Smart Agriculture v3.0 not reading sensors

Post by IoTmonsta » Wed Jun 19, 2019 10:46 am

Guys, so, we got a Smart Agriculture board 3.0 with a Waspmote Plug & Sense 1.5 with Sigfx communications. All works fine except we cannot see any data coming from the Smart Agriculture board v3.0 (meaning from the sensors)

Is there any way to get some help from you to see if these boards are working correctly?
We know the main board works because we can connect to it via your Libelium IDE and see data we see in the serial port monitor. We also know the Sigfox communications board works well because we can send data to the Sigfox network.

What we cannot be sure it works, is the Smart Agriculture Board since none of the sensors we have tried show any data. It shows the same values for both sensors with or without the sensors plugged in. We tried the sensors in Arduino board as well and they work fine.

We also tried other two Smart Agriculture boards and cannot read anything on them. Wondering if we are doing something wrong. We have loaded just your sample programs to test the sensors individuals but no result reading any data.

Is there any way to know if the Smart Agriculture Board is working?
We tried 3 different boards in two different mainboards and is always the same result. No sensor data.

The sensors we have are:
1x Soil temperature (DS18B20)
1x Soil moisture 4.5 m (Watermark)

Any help would be welcome! -Thanks!

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Smart Agriculture v3.0 not reading sensors

Post by libelium-dev » Wed Jun 19, 2019 12:56 pm

Hi,

Could you please share some detailed images of your devices with us?

How are the sensors connected to the board? Please share some images too.

Are you using the last API v041 to avoid bugs fixed? Did you use the following example codes to test the sensors?
http://www.libelium.com/development/was ... r-reading/
http://www.libelium.com/development/was ... r-reading/

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest