4G module start

Wireless communications in Waspmote, topologies, node types...
Post Reply
ecostas
Posts: 11
Joined: Wed May 09, 2018 7:54 pm
Company: ecostas

4G module start

Post by ecostas » Mon Sep 30, 2019 7:06 am

Hello;

I just received two waspmote with 4G.

After several problems with my code. For check, I load your example 4G_07 - HTTP POST.


This is is the return:

J#
Start program
********************************************************************
POST method to the Libelium's test url
You can use this php to test the HTTP connection of the module.
The php returns the parameters that the user sends with the URL.
********************************************************************
*****************************
APN: NXT17C.NET
LOGIN:
PASSWORD:
*****************************
J#
Start program
********************************************************************
POST method to the Libelium's test url
You can use this php to test the HTTP connection of the module.
The php returns the parameters that the user sends with the URL.
********************************************************************
*****************************
APN: NXT17C.NET
LOGIN:
PASSWORD:
*****************************
J#
Start program
********************************************************************
POST method to the Libelium's test url
You can use this php to test the HTTP connection of the module.
The php returns the parameters that the user sends with the URL.
********************************************************************
*****************************
APN: NXT17C.NET
LOGIN:
PASSWORD:
*****************************

The same problem with my code and with your example code, When _4G.show_APN() is executed the code stops and reboot all the time. No error message returns.

Can you help me?

I use api v042

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: 4G module start

Post by libelium-dev » Mon Sep 30, 2019 9:59 am

Hi,

Could you please check the battery level of the node?
http://www.libelium.com/development/was ... ery-level/

The 4G module has a high current consumption when it is power ON. If the battery level is low, the node could restart due to the battery can provide the needed current.

Regards

ecostas
Posts: 11
Joined: Wed May 09, 2018 7:54 pm
Company: ecostas

Re: 4G module start

Post by ecostas » Mon Sep 30, 2019 1:04 pm

I don't use battery. I connect the waspmote directly computer USB.

Is possible use module 4G without battery?

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: 4G module start

Post by libelium-dev » Mon Sep 30, 2019 1:48 pm

Hi,

No, it's not possible to use the 4G module without the battery since the 4G module is powered from the battery since it has current peaks that the USB port can't provide.

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest