4G Https issue

Wireless communications in Waspmote, topologies, node types...
Post Reply
RobB
Posts: 13
Joined: Tue May 30, 2017 11:03 am

4G Https issue

Post by RobB » Wed Oct 16, 2019 2:32 pm

Hi I'm using a Smart Environment Pro 4G unit 05533F057C105470

I have been sending data to my own webserver but I recently got a fixed IP sim card for my Meshlium so I wanted to send frames to the Meshlium instead of the webserver.
When I use the PCS to program the SMP it returns error 20. On reading the 4G manual it seems that the Telit 4G unit I have is not compatible with https?
Is this correct?

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: 4G Https issue

Post by libelium-dev » Thu Oct 17, 2019 8:53 am

Hi,

The 4G module can perform HTTPS requests through SSL sockets. You can find an example code in the following link.
http://www.libelium.com/development/was ... ium-https/

Regards

RobB
Posts: 13
Joined: Tue May 30, 2017 11:03 am

Re: 4G Https issue

Post by RobB » Thu Oct 17, 2019 12:12 pm

Thank you.
I use the Programming Cloud Service normally.
I used your test service first (test.libelium.com) - works normally.
Loading your example with the IDE (Correct APN and IP address applied) I get the following message:

1. 4G module ready...
2.1. Create frame:
===============================
Current ASCII Frame:
Length: 47
Frame Type: 134
frame (HEX): 3C3D3E86012330353533334630353743313035343730236E6F64655F303123322354494D453A31302D33342D343723
frame (STR): <=>†#05533F057C105470#node_01#2#TIME:10-34-47#
===============================
2.2 Data to send:
-----------------------------------------
GET /getpost_frame_parser.php?frame=3C3D3E86012330353533334630353743313035343730236E6F64655F303123322354494D453A31302D33342D343723 HTTP/1.1
Host: 31.129.125.137
Content-Length: 0


-----------------------------------------
2.1. Error opening socket. Error code: 20
3. Switch OFF 4G module
5. Enter deep sleep...
6. Wake up!!

I am concerned about the certificate - the format of my exported certificate text is different to the example.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: 4G Https issue

Post by libelium-dev » Fri Oct 18, 2019 9:04 am

Hi,

Could you please share the code used with us?

You have to open de .crt file using a text editor and then copy it in the code adding the quotation marks and the \r ant the end of each line.

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest