PM sensor reporting bad values when air hummidity is high

Post Reply
rokkres
Posts: 2
Joined: Wed Jan 08, 2020 10:47 am
Company: Rok Kreslin s.p.

PM sensor reporting bad values when air hummidity is high

Post by rokkres » Wed Jan 08, 2020 1:09 pm

Hi,

I have similar problem to the one described in this thread: https://www.libelium.com/forum/viewtopi ... 26&t=23261. If air hummidity gets high, PM sensor starts to report unusually high values for PM1, PM2.5 and PM10 (up to few million ug/m3). Did you manage to solve the issue?

I can also send you excel spreedsheat with the reported values if it helps.

Thank you in advance.

Best regads,
Rok

rokkres
Posts: 2
Joined: Wed Jan 08, 2020 10:47 am
Company: Rok Kreslin s.p.

Re: PM sensor reporting bad values when air hummidity is high

Post by rokkres » Thu Jan 09, 2020 6:57 am

Please move this post to plug & sense board since that's the configuratioj we are using. I'm sorry for the inconvenience.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: PM sensor reporting bad values when air hummidity is high

Post by libelium-dev » Fri Jan 10, 2020 8:54 am

Hi,

What is the humidity level when the PM report incorrect values? Is it an OPC-N2 or OPC-N3?

The PM sensor is a digital sensor and the P&S reads the reported values. We can't fix the behaviour of the PM sensor since the P&S only reads the returned values, it doesn't configure anything to the sensor. Let us know when the sensors start to report incorrect values and we will contact the manufacturer to try to solve the issue.

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests