LORA Server Change - Join Request Issues?

Post Reply
woody_747
Posts: 14
Joined: Wed Feb 07, 2018 3:12 pm
Company: InTechnology WiFi

LORA Server Change - Join Request Issues?

Post by woody_747 » Tue Sep 03, 2019 2:23 pm

Hi,

I have just changed the loraserver instance we are using to connect our 5 plug and sense devices but they are now no longer communicating.

I have mirrored the DevEui and App Key and then moved the gateways over to the new server.

Do I need to reset the Plug and Sense device for them to send a join request? I thought they did this after each sleep as part of the loop?

Code is configured using your online programming tool.

Cheers

Kris

woody_747
Posts: 14
Joined: Wed Feb 07, 2018 3:12 pm
Company: InTechnology WiFi

Re: LORA Server Change - Join Request Issues?

Post by woody_747 » Wed Sep 04, 2019 10:43 am

Hi Libelium,

A response to this would be appreciated. All 5 of our sensors are currently offline.

Kind Regards

Kris

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: LORA Server Change - Join Request Issues?

Post by libelium-dev » Wed Sep 04, 2019 11:06 am

Hi,

It's needed to reset the nodes since the nodes need to configure the session keys with the server again.

The operation of the nodes is as follow
- The nodes join OTAA in the setup and negotiate the session keys (ABP) with the server.
- The nodes join ABP in the loop using the negotiate keys.
- You have configured the same OTAA keys in your server but the ABP keys have changed.
- Resetting the nodes, they will update the ABP keys.

Regards

woody_747
Posts: 14
Joined: Wed Feb 07, 2018 3:12 pm
Company: InTechnology WiFi

Re: LORA Server Change - Join Request Issues?

Post by woody_747 » Wed Sep 04, 2019 4:28 pm

Ok no worries, thanks.

Kris

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: LORA Server Change - Join Request Issues?

Post by libelium-dev » Thu Sep 05, 2019 7:50 am

You're welcome!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest