I do not read the values (pH, battery) from Meshlium Web

Post Reply
josemaria
Posts: 59
Joined: Thu Sep 15, 2016 10:57 am

I do not read the values (pH, battery) from Meshlium Web

Post by josemaria » Tue Feb 21, 2017 4:24 pm

Hi!

I am using a Smart Water - Plug & Sense!. I do not read the values (pH, battery) from Meshlium Web interface. I select the sensor node. The output is always Generating results ...

Please, could you help me?.

Thank you.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: I do not read the values (pH, battery) from Meshlium Web

Post by libelium-dev » Wed Feb 22, 2017 12:14 pm

Hi josemaria,

Please enter your Meshlium via ssh:

User: root
Password: libelium

Code: Select all

ssh root@YOUR_MESHLIUM_IP
To diagnose this, you can activate the logs of sensorParser. To do this, edit the file "/mnt/lib/cfg/parser/log_setup" and set it to "3". Then you can restart the parser with:

Code: Select all

sensorParserD.sh stop
sensorParserD.sh start
You can display the logs with:

Code: Select all

tail -f /mnt/user/logs/sensorParser.log

Code: Select all

tail -f /mnt/user/logs/sensor.log
In the logs you will see what is happening with your frame and if it is realy reaching Meshlium.

Best regards

josemaria
Posts: 59
Joined: Thu Sep 15, 2016 10:57 am

Re: I do not read the values (pH, battery) from Meshlium Web

Post by josemaria » Wed Feb 22, 2017 6:07 pm

Hi!

thanks for your response.

When I execute this code:
tail -f /mnt/user/logs/sensorParser.log

The output is the following:
Read:
Buffer:
Buffer size: 0
number of frames: 0

The Meshlium Web interface is always generating results ... but no data.

What could be the problem?. Thank you.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: I do not read the values (pH, battery) from Meshlium Web

Post by libelium-dev » Thu Feb 23, 2017 3:43 pm

Hi josemaria,

If you are not getting data on Meshlium from Waspmote you should get a closer look to your Waspmote code, our colleagues from Waspmote forum can help you.

Regards

josemaria
Posts: 59
Joined: Thu Sep 15, 2016 10:57 am

Re: I do not read the values (pH, battery) from Meshlium Web

Post by josemaria » Thu Feb 23, 2017 4:10 pm

Hi!

I already read the values from Meshlium Web interface. I see a graph. But, how could I read the on-demand sensor node values?. The value directly from the sensor node. Live. I am interesed in generating Zigbee/IEEE 802.15.4 packets between a sensor node and Meshlium.

Please, could you help me?.

Thank you.

Regards,

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: I do not read the values (pH, battery) from Meshlium Web

Post by libelium-dev » Fri Feb 24, 2017 9:14 am

Hi,

To send packets from Waspmote to meshlium, you must configure Waspmote with the same PANID and channel that Meshlium, you can use this example. Then, you can use the example to send packets.

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest