There are no Serial Port in the Device Manager

Post Reply
MIKron
Posts: 23
Joined: Wed Feb 27, 2019 9:20 am
Company: Ability

There are no Serial Port in the Device Manager

Post by MIKron » Wed Feb 27, 2019 10:43 am

Good day!

We are new to Waspmote and starting to learn about it. First of all, I installed driver for USB Serial Converter ( https://www.ftdichip.com/Support/Docume ... s%2010.pdf ), but USB Serial Port didn't appeared for me :

Image

What I am doing wrong? All switches are ON position on board.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: There are no Serial Port in the Device Manager

Post by libelium-dev » Thu Feb 28, 2019 9:44 am

Hi,

You should see the device as a COM port. Dos you see COM ports in the Waspmote IDE? Did you try to upload code?

Regards

MIKron
Posts: 23
Joined: Wed Feb 27, 2019 9:20 am
Company: Ability

Re: There are no Serial Port in the Device Manager

Post by MIKron » Thu Feb 28, 2019 9:59 am

Hi,

Yes, COM1 available in the IDE. But I can't upload code:

Arduino: Waspmote PRO IDE (Windows 10), Board: "Waspmote API v038"

Sketch uses 78,940 bytes (64%) of program storage space. Maximum is 122,880 bytes.
Global variables use 6,022 bytes (73%) of dynamic memory, leaving 2,170 bytes for local variables. Maximum is 8,192 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x03
Problem uploading to board. See index.php for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: There are no Serial Port in the Device Manager

Post by libelium-dev » Fri Mar 01, 2019 9:19 am

Hi,

Could you please share some images of waspmote? Could you try with another computer?

Regards

MIKron
Posts: 23
Joined: Wed Feb 27, 2019 9:20 am
Company: Ability

Re: There are no Serial Port in the Device Manager

Post by MIKron » Fri Mar 01, 2019 9:45 am

Image

More images can be made after weekends, if needed. We need waspmote for this particular machine. But we can try find another computer to test.

MIKron
Posts: 23
Joined: Wed Feb 27, 2019 9:20 am
Company: Ability

Re: There are no Serial Port in the Device Manager

Post by MIKron » Mon Mar 04, 2019 6:50 am

OK, we tried Windows 7 instead Windows 10 and now we have USB Serial Port (COM97). But It seems that device initialization isn't successful :

Image

setup() is repeated again and again, but there is said that initialization performed one time and then loop() executed in documentation, right? What could be source of such behavior?

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: There are no Serial Port in the Device Manager

Post by libelium-dev » Wed Mar 06, 2019 4:02 pm

Hi,

Did you connect the battery to Waspmote? It seems that the node reboots since the USB port can't supply the needed current supply.

Regards

MIKron
Posts: 23
Joined: Wed Feb 27, 2019 9:20 am
Company: Ability

Re: There are no Serial Port in the Device Manager

Post by MIKron » Tue Mar 12, 2019 3:56 pm

Hi,

You are right, we forget about battery. Thank you!

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: There are no Serial Port in the Device Manager

Post by libelium-dev » Wed Mar 13, 2019 9:08 am

Glad to hear that the problem was solved! :D

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest