Meshlium LoraProblem

All related to the Kernel, packages system and libraries
Post Reply
aliparto
Posts: 5
Joined: Fri Jul 29, 2016 2:57 pm

Meshlium LoraProblem

Post by aliparto » Sun Jul 31, 2016 8:02 am

Hi,

I have a Meshlium with Lora Sx1272 Module.
First, I check the status of the Lora and everything was ok, but recently when I try to change the frequency and check the status to make sure the parameter has been set I got some warnings.
Would you please advise how to troubleshoot the problem.
https://www.imageupload.co.uk/images/2016/07/31/BUG.png

Best Regards
Ali

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Meshlium LoraProblem

Post by libelium-dev » Mon Aug 01, 2016 8:31 am

Hi aliparto,

Please check your USBs with this command:

Code: Select all

ll /dev/tty/USB*
Also, can you tell us your Meshlium model?

Regards

aliparto
Posts: 5
Joined: Fri Jul 29, 2016 2:57 pm

Re: Meshlium LoraProblem

Post by aliparto » Mon Aug 01, 2016 12:31 pm

Thanks for your replay.
I connected to to the Meshlium and check the command, the result was as below:
ls: cannot access /dev/tty/USB*: Not a directory

My Meshlium is: Meshlium LoRa SX1272 AP (With 3G)

Best Regards
Ali

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Meshlium LoraProblem

Post by libelium-dev » Mon Aug 01, 2016 12:53 pm

Hi aliparto,

Sorry, there was a misunderstood with the command, please time this one:

Code: Select all

ll /dev/ttyUSB*
Regards

aliparto
Posts: 5
Joined: Fri Jul 29, 2016 2:57 pm

Re: Meshlium LoraProblem

Post by aliparto » Mon Aug 01, 2016 12:58 pm

Hi,

OK, I check it and and got this:
14277 crw-rw---- 1 root dialout 188, 0 2016-07-13 15:29 /dev/ttyUSB0

Best Regards

aliparto
Posts: 5
Joined: Fri Jul 29, 2016 2:57 pm

Re: Meshlium LoraProblem

Post by aliparto » Mon Aug 01, 2016 1:15 pm

Hi,
Sorry, I got these line:

11194 crw-rw---- 1 root dialout 188, 0 2016-07-13 15:43 /dev/ttyUSB0
11205 crw-rw---- 1 root dialout 188, 1 2016-07-13 15:43 /dev/ttyUSB1

Best Regards

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Meshlium LoraProblem

Post by libelium-dev » Mon Aug 01, 2016 2:04 pm

Hi aliparto,

Your LoRa should be present in USB1. Please execute this command to know if your USB LoRa is busy:

Code: Select all

lsof /dev/ttyUSB1
Please put the output here.

Regards

aliparto
Posts: 5
Joined: Fri Jul 29, 2016 2:57 pm

Re: Meshlium LoraProblem

Post by aliparto » Tue Aug 02, 2016 4:25 pm

The problem was solved.

Thanks

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: Meshlium LoraProblem

Post by libelium-dev » Tue Aug 02, 2016 4:39 pm

Hi aliparto,

Glad to heard that, if you have more question please do not hesitate and drop us a line.

Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest