New Parking Sensor with Radar Tech

jluengo83
Posts: 30
Joined: Tue Sep 18, 2018 10:04 pm
Company: Conure Telecom

New Parking Sensor with Radar Tech

Post by jluengo83 » Wed Sep 11, 2019 11:34 pm

Hi,

I'm trying to install the new firmware v1.0.4 but is giving an error shown below:

"Problems installing firmware, please delete and download it again"

I tried the mentioned above but still showing the same error, and I have also tried installing other firmwares but same error.

The reason that I'm doing it is that the sensor is only sending 3 frames after turning on/calibrate, then it does not continue working such as detecting occupancy, I wonder if by upgrading firmware would fix the problem.


Could you please help to troubleshoot.


Thanks

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: New Parking Sensor with Radar Tech

Post by libelium-dev » Thu Sep 12, 2019 2:44 pm

Hi,

The firmware v1.0.4 improves the current consumption when there isn't a LoRaWAN network enabled. The detection works like the other firmware versions. Anyway, we recommend updating the firmware to the latest.

Could you please share with us the 3 frames received? Is the node installed? Or are you simulating the occupancy?

Regarding the problem installing the firmware, did you open the app with administration permission? Is the node in boot mode? Did you set your libelium cloud credentials in the app? Is the node register in your libelium cloud account?

Regards

jluengo83
Posts: 30
Joined: Tue Sep 18, 2018 10:04 pm
Company: Conure Telecom

Re: New Parking Sensor with Radar Tech

Post by jluengo83 » Thu Sep 12, 2019 5:58 pm

Hi,

What do you mean when there is not LoraNetwork enabled?

Find below the frames:

FCntUp Time Port Data
3 20 hours ago 3 11 03 00 19 06 09 00 00 00 00 90
2 20 hours ago 3 05 02 00 14 01 00 00 06 05 04 00
1 20 hours ago 3 04 01 0b ad 19 14 3c 01 01 01 00
0 20 hours ago 3 04 00 0b ad 19 14 3c 01 01 01 00

Yes, I did open the app with admin rights, the node is in boot mode, the cloud credentials were set time ago as we are using 10 new sensors with radar technology, the node is also registered as the other nodes have were registered when we received the sensors.


Thank You.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: New Parking Sensor with Radar Tech

Post by libelium-dev » Fri Sep 13, 2019 9:20 am

Hi,

We mean when there isn't lorawan network close to the node, for example, the gateway is off and therefore the node can't send data to the server.

What OS do you use? Is the usb port selected?

Did the node work before? The keep-alive is set to 1 hour, is that frame received after one hour? Is the node installed?

Do the other nodes work properly?

Regards

jluengo83
Posts: 30
Joined: Tue Sep 18, 2018 10:04 pm
Company: Conure Telecom

Re: New Parking Sensor with Radar Tech

Post by jluengo83 » Fri Sep 13, 2019 6:08 pm

Hi,

Thanks for the clarification regarding to LoraWan Enabled.

I'm using Windows 7 Pro SP1. Yes, when the node is Boot Mode/ON, then from the App I can see the USB1, and I can load the settings from the sensor as well as flashing the new settings to the sensor.

Yes, the Node worked before. The keep-alive is set to 1H, I don't see that the node is sending a frame after 1H. The node was installed before in the parking lot and I brought it to my office for troubleshooting as it did stop working correctly.

The other nodes are working fine, except one that does not power ON due to the battery issue that I'm sending to Libelieum trough RMA process.

Looking forward to the solution on this sensor.


Thank You.

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: New Parking Sensor with Radar Tech

Post by libelium-dev » Mon Sep 16, 2019 3:30 pm

Hi,

Please try to download the smart devices app again since it was updated a few days ago. Then please open the /cfg/config.ini file and set log_level = debug. It will generate a log file called SmartDevicesApp.log. Finally, please try to upload the firmware again, if it returns an error, copy here the SmartDevicesApp.log file to debug the issue in more deep.

Regarding the problem with the node, could you please check the battery voltage with a voltmeter? Try to update the firmware and let us know if the problem is solved.

Regards

jluengo83
Posts: 30
Joined: Tue Sep 18, 2018 10:04 pm
Company: Conure Telecom

Re: New Parking Sensor with Radar Tech

Post by jluengo83 » Tue Sep 17, 2019 8:11 pm

Hi,

I followed accordingly but still showing the same error "Problems installing the firmware, please delete and download it again".

Find below the log file information generated:

2019-09-17 14:01:43.030 [AWT-EventQueue-0] INFO com.libelium.smartdevicesapp.SmartDeviceApp - log level selected from config: debug
2019-09-17 14:01:45.827 [AWT-EventQueue-0] DEBUG com.libelium.smartdevicesapp.SmartDeviceApp - REFRESH PORTS
2019-09-17 14:01:46.842 [AWT-EventQueue-0] DEBUG com.libelium.utils.STM32Programmer -
-------------------------------------------------------------------
STM32CubeProgrammer v2.1.0
-------------------------------------------------------------------

===== DFU Interface =====

No STM32 device in DFU mode connected


2019-09-17 14:01:46.843 [AWT-EventQueue-0] DEBUG com.libelium.utils.STM32Programmer - [Ljava.lang.String;@7d52ffbd
2019-09-17 14:01:46.844 [AWT-EventQueue-0] DEBUG com.libelium.smartdevicesapp.SmartDeviceApp - REFRESH PORTS
2019-09-17 14:01:47.010 [AWT-EventQueue-0] DEBUG com.libelium.smartdevicesapp.SmartDeviceApp - REFRESH PORTS
2019-09-17 14:01:59.350 [AWT-EventQueue-0] DEBUG com.libelium.smartdevicesapp.SmartDeviceApp - REFRESH PORTS
2019-09-17 14:02:30.518 [SwingWorker-pool-3-thread-7] DEBUG com.libelium.utils.STM32Programmer -
-------------------------------------------------------------------
STM32CubeProgrammer v2.1.0
-------------------------------------------------------------------

===== DFU Interface =====

Total number of available STM32 device in DFU mode: 1

Device Index : USB1
USB Bus Number : 001
USB Address Number : 003
Product ID : STM32 BOOTLOADER
Serial number : 208336674142
Firmware version : 0x011a
Device ID : 0x0415


2019-09-17 14:02:30.519 [SwingWorker-pool-3-thread-7] DEBUG com.libelium.utils.STM32Programmer - [Ljava.lang.String;@1b00735d
2019-09-17 14:02:31.870 [SwingWorker-pool-3-thread-8] DEBUG com.libelium.utils.STM32Programmer -
-------------------------------------------------------------------
STM32CubeProgrammer v2.1.0
-------------------------------------------------------------------

===== DFU Interface =====

Total number of available STM32 device in DFU mode: 1

Device Index : USB1
USB Bus Number : 001
USB Address Number : 003
Product ID : STM32 BOOTLOADER
Serial number : 208336674142
Firmware version : 0x011a
Device ID : 0x0415


2019-09-17 14:02:31.871 [SwingWorker-pool-3-thread-8] DEBUG com.libelium.utils.STM32Programmer - [Ljava.lang.String;@251d38c1
2019-09-17 14:02:31.910 [AWT-EventQueue-0] DEBUG com.libelium.smartdevicesapp.SmartDeviceApp - LOAD FROM NODE button pressed
2019-09-17 14:02:31.999 [SwingWorker-pool-3-thread-9] DEBUG com.libelium.utils.STM32Programmer -
-------------------------------------------------------------------
STM32CubeProgrammer v2.1.0
-------------------------------------------------------------------

===== DFU Interface =====

Total number of available STM32 device in DFU mode: 1

Device Index : USB1
USB Bus Number : 001
USB Address Number : 003
Product ID : STM32 BOOTLOADER
Serial number : 208336674142
Firmware version : 0x011a
Device ID : 0x0415


2019-09-17 14:02:32.000 [SwingWorker-pool-3-thread-9] DEBUG com.libelium.utils.STM32Programmer - [Ljava.lang.String;@1f2c0052
2019-09-17 14:02:32.000 [SwingWorker-pool-3-thread-9] DEBUG com.libelium.utils.STM32Programmer - Starting STM32 Programmer CLI for windows 7
2019-09-17 14:02:32.000 [SwingWorker-pool-3-thread-9] DEBUG com.libelium.utils.STM32Programmer - .\tools\stm32\stm32_windows\STMicroelectronics\STM32Cube\STM32CubeProgrammer\bin\STM32_Programmer_CLI.exe -c port=usb1
--read 0x080f0440 0xff temp\temp_readable_config_spv2.bin
2019-09-17 14:02:32.206 [SwingWorker-pool-3-thread-9] DEBUG com.libelium.utils.STM32Programmer -
-------------------------------------------------------------------
STM32CubeProgrammer v2.1.0
-------------------------------------------------------------------

Warning: Wrong connect parameter:


USB speed : Full Speed (12MBit/s)
Manuf. ID : STMicroelectronics
Product ID : STM32 BOOTLOADER
SN : 208336674142
FW version : 0x011a
Device ID : 0x0415
Device name : STM32L4x1/STM32L475xx/STM32L476xx/STM32L486xx
Device type : MCU
Device CPU : Cortex-M4


UPLOADING ...
File : temp\temp_readable_config_spv2.bin
Size : 255 Bytes
Address: : 0x80F0440
Read progress:
?????????????????????????????????????????????????? 0%
?????????????????????????????????????????????????? 100%
Data read successfully
Time elapsed during read operation is: 00:00:00.009

2019-09-17 14:02:32.216 [SwingWorker-pool-3-thread-9] DEBUG com.libelium.utils.STM32Programmer - Pattern OK match.
2019-09-17 14:02:32.216 [SwingWorker-pool-3-thread-9] DEBUG com.libelium.utils.STM32Programmer - enter true command
2019-09-17 14:02:43.540 [AWT-EventQueue-0] DEBUG com.libelium.smartdevicesapp.SmartDeviceApp - LOAD FIRMWARE
2019-09-17 14:03:26.029 [AWT-EventQueue-0] DEBUG com.libelium.smartdevicesapp.SmartDeviceApp - DOWNLOAD FIRMWARE
2019-09-17 14:03:33.381 [AWT-EventQueue-0] DEBUG com.libelium.smartdevicesapp.SmartDeviceApp - INSTALL SMARTPARKING v2 FIRMWARE
2019-09-17 14:03:33.420 [AWT-EventQueue-0] ERROR com.libelium.smartdevicesapp.SmartDeviceApp - java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter
java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter
at java.util.concurrent.FutureTask.report(Unknown Source) ~[?:?]
at java.util.concurrent.FutureTask.get(Unknown Source) ~[?:?]
at javax.swing.SwingWorker.get(Unknown Source) ~[?:?]
at com.libelium.smartdevicesapp.SmartDeviceApp$109.done(SmartDeviceApp.java:5977) [SmartDevicesApp.jar:?]
at javax.swing.SwingWorker$5.run(Unknown Source) [?:?]
at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.run(Unknown Source) [?:?]
at sun.swing.AccumulativeRunnable.run(Unknown Source) [?:?]
at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.actionPerformed(Unknown Source) [?:?]
at javax.swing.Timer.fireActionPerformed(Unknown Source) [?:?]
at javax.swing.Timer$DoPostEvent.run(Unknown Source) [?:?]
at java.awt.event.InvocationEvent.dispatch(Unknown Source) [?:?]
at java.awt.EventQueue.dispatchEventImpl(Unknown Source) [?:?]
at java.awt.EventQueue.access$600(Unknown Source) [?:?]
at java.awt.EventQueue$4.run(Unknown Source) [?:?]
at java.awt.EventQueue$4.run(Unknown Source) [?:?]
at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source) [?:?]
at java.awt.EventQueue.dispatchEvent(Unknown Source) [?:?]
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source) [?:?]
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source) [?:?]
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source) [?:?]
at java.awt.WaitDispatchSupport$2.run(Unknown Source) [?:?]
at java.awt.WaitDispatchSupport$4.run(Unknown Source) [?:?]
at java.awt.WaitDispatchSupport$4.run(Unknown Source) [?:?]
at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
at java.awt.WaitDispatchSupport.enter(Unknown Source) [?:?]
at java.awt.Dialog.show(Unknown Source) [?:?]
at java.awt.Component.show(Unknown Source) [?:?]
at java.awt.Component.setVisible(Unknown Source) [?:?]
at java.awt.Window.setVisible(Unknown Source) [?:?]
at java.awt.Dialog.setVisible(Unknown Source) [?:?]
at com.libelium.smartdevicesapp.SmartDeviceApp.btnInstall_SmPv2ActionPerformedv2(SmartDeviceApp.java:5999) [SmartDevicesApp.jar:?]
at com.libelium.smartdevicesapp.SmartDeviceApp.access$8000(SmartDeviceApp.java:137) [SmartDevicesApp.jar:?]
at com.libelium.smartdevicesapp.SmartDeviceApp$71.actionPerformed(SmartDeviceApp.java:3897) [SmartDevicesApp.jar:?]
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source) [?:?]
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source) [?:?]
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source) [?:?]
at javax.swing.DefaultButtonModel.setPressed(Unknown Source) [?:?]
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source) [?:?]
at java.awt.Component.processMouseEvent(Unknown Source) [?:?]
at javax.swing.JComponent.processMouseEvent(Unknown Source) [?:?]
at java.awt.Component.processEvent(Unknown Source) [?:?]
at java.awt.Container.processEvent(Unknown Source) [?:?]
at java.awt.Component.dispatchEventImpl(Unknown Source) [?:?]
at java.awt.Container.dispatchEventImpl(Unknown Source) [?:?]
at java.awt.Component.dispatchEvent(Unknown Source) [?:?]
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source) [?:?]
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source) [?:?]
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source) [?:?]
at java.awt.Container.dispatchEventImpl(Unknown Source) [?:?]
at java.awt.Window.dispatchEventImpl(Unknown Source) [?:?]
at java.awt.Component.dispatchEvent(Unknown Source) [?:?]
at java.awt.EventQueue.dispatchEventImpl(Unknown Source) [?:?]
at java.awt.EventQueue.access$600(Unknown Source) [?:?]
at java.awt.EventQueue$4.run(Unknown Source) [?:?]
at java.awt.EventQueue$4.run(Unknown Source) [?:?]
at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source) [?:?]
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source) [?:?]
at java.awt.EventQueue$5.run(Unknown Source) [?:?]
at java.awt.EventQueue$5.run(Unknown Source) [?:?]
at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source) [?:?]
at java.awt.EventQueue.dispatchEvent(Unknown Source) [?:?]
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source) [?:?]
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source) [?:?]
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source) [?:?]
at java.awt.EventDispatchThread.pumpEvents(Unknown Source) [?:?]
at java.awt.EventDispatchThread.pumpEvents(Unknown Source) [?:?]
at java.awt.EventDispatchThread.run(Unknown Source) [?:?]
Caused by: java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter
at com.libelium.smartdevicesapp.devices.DeviceSmartParking2.install(DeviceSmartParking2.java:131) ~[SmartDevicesApp.jar:?]
at com.libelium.smartdevicesapp.SmartDeviceApp$109.doInBackground(SmartDeviceApp.java:5966) ~[SmartDevicesApp.jar:?]
at com.libelium.smartdevicesapp.SmartDeviceApp$109.doInBackground(SmartDeviceApp.java:5961) ~[SmartDevicesApp.jar:?]
at javax.swing.SwingWorker$1.call(Unknown Source) ~[?:?]
at java.util.concurrent.FutureTask.run(Unknown Source) ~[?:?]
at javax.swing.SwingWorker.run(Unknown Source) ~[?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) ~[?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) ~[?:?]
at java.lang.Thread.run(Unknown Source) ~[?:?]
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter
at jdk.internal.loader.BuiltinClassLoader.loadClass(Unknown Source) ~[?:?]
at jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(Unknown Source) ~[?:?]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:?]
at com.libelium.smartdevicesapp.devices.DeviceSmartParking2.install(DeviceSmartParking2.java:131) ~[SmartDevicesApp.jar:?]
at com.libelium.smartdevicesapp.SmartDeviceApp$109.doInBackground(SmartDeviceApp.java:5966) ~[SmartDevicesApp.jar:?]
at com.libelium.smartdevicesapp.SmartDeviceApp$109.doInBackground(SmartDeviceApp.java:5961) ~[SmartDevicesApp.jar:?]
at javax.swing.SwingWorker$1.call(Unknown Source) ~[?:?]
at java.util.concurrent.FutureTask.run(Unknown Source) ~[?:?]
at javax.swing.SwingWorker.run(Unknown Source) ~[?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) ~[?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) ~[?:?]
at java.lang.Thread.run(Unknown Source) ~[?:?]


Regarding the Node battery issue:

https://www.libelium.com/forum/viewtopi ... 66&t=26464


Looking forward to your reply.


Thanks!

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: New Parking Sensor with Radar Tech

Post by libelium-dev » Wed Sep 18, 2019 1:07 pm

Hi,

It seems that the problem is related to Java8 isn't installed. Please install it and try again.
https://docs.oracle.com/javase/8/docs/t ... rview.html
https://www.oracle.com/technetwork/java ... 33155.html

Regards

jluengo83
Posts: 30
Joined: Tue Sep 18, 2018 10:04 pm
Company: Conure Telecom

Re: New Parking Sensor with Radar Tech

Post by jluengo83 » Thu Sep 19, 2019 6:55 pm

Hi,

After downloading Java 8 as requested I was able to upgrade the firmware to 1.0.4 but the sensor is not longer sending frames.

I Turned off the sensor then switched to APP, then turned ON, closed the lid, tighten the screws, placed over the floor, did a calibration (3 times as per the manual) but no frames are being sent.

By the way, I see the LED activity which means the battery is powering UP the sensor.


Looking forward to your reply.


Thanks

libelium-dev
Posts: 27967
Joined: Mon Sep 28, 2009 1:06 pm

Re: New Parking Sensor with Radar Tech

Post by libelium-dev » Fri Sep 20, 2019 2:25 pm

Hi Jorge,

Our colleagues from tech have just contacted you to find the best solution.

Apologies for the inconvenience.
Regards

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest